jueves, 16 de octubre de 2014

SIAPE vs Java

Si llegaste a este POST seguramente sos empleado de la Provincia de Buenos Aires o soporte técnico de alguna dependencia estatal, que, necesariamente tiene que utilizar el SIAPE (Sistema Único Provincial de Administración de Personal).


Este sistema web utiliza en varias de sus aplicaciones Java.  Java es una tecnología que se usa para el desarrollo de aplicaciones que convierten a la Web en un elemento más interesante y útil. Java no es lo mismo que javascript, que se trata de una tecnología sencilla que se usa para crear páginas web y solamente se ejecuta en el explorador.

Java le permite jugar, cargar fotografías, chatear en línea, realizar visitas virtuales y utilizar servicios como, por ejemplo, cursos en línea, servicios bancarios en línea y mapas interactivos. Si no dispone de Java, muchas aplicaciones y sitios web no funcionarán.



Hasta acá todo muy lindo, pero lo cierto es que el Siape con Java no se llevan muy bien que digamos, siempre aparecen problemitas, después de una actualización de windows, luego de una actualización de Java, al actualizarse el navegador, en fin, por varias razones este programa deja de funcionar.

A continuación dejo una lista con los problemas más frecuentes y las soluciones:


1) El error más común: "FRM-92095: Versión de Oracle JInitiator demasiado baja."



2) Otro error sistémico: "JAVA: Aplicación bloqueada por configuración de seguridad."



3) Problemas al actualizar Java Version 7 Update 51

Java se actualiza automáticamente por internet cada vez que aparece una nueva versión o actualización del software. En ocaciones la actualización Online falla y no se puede completar el proceso, en este caso es necesario hacer una instalación offline.




4) Problemas de ejecución de SIAPE en una plataforma Windows de 64 bits

Las soluciones anteriores funcionan perfecto en arquitecturas de 32 bits, pero no dan auxilio en versiones de windows de 64 bits. Opté por una solución, poco elegante, pero rápida y efectiva.



5) Configuración de seguridad en la versión 8 de Java

En el punto 2 de este post hablo sobre un error de seguridad que se soluciona facilmente. Bueno, funciona si la versión de Java es inferior a la 8.